Widget Availability And Usage Limits
Resolved
May 26, 2026 at 10:30pm UTC
Widget Availability And Usage Limits (RESOLVED)
Affected services
Created
May 26, 2026 at 9:30pm UTC
Summary
On May 26 starting at 5:30pm EST, Aimdoc experienced degraded widget behavior for some customers due to provider usage limits being reached earlier than expected.
Two systems were affected: location enrichment and AI response generation. Both issues have been mitigated, and service has been restored.
Impact
Some visitors may have experienced delayed, incomplete, or failed AI responses in the widget. Location-based visitor enrichment was also temporarily degraded.
Core application data remained safe. No customer data was lost.
What Happened
We observed an abnormal pattern of high-volume datacenter based widget traffic that caused our location enrichment provider quota to be consumed faster than expected.
Separately, our upstream model provider usage limit was reached unexpectedly, causing some AI generation requests to fail. We are continuing to review why provider-side quota behavior differed from our expectations.
Resolution
Our usage limits were increased by 6:30pm EST.
We deployed additional safeguards to limit high-velocity datacenter traffic from consuming enrichment resources while preserving normal behavior for real visitor engagement.
We also restored AI generation availability and added monitoring around model provider usage limits.
Current Status
The incident has been mitigated. Widget functionality and AI responses are operating normally.
Affected services